No puedo activar opencl

Hola,
Llevo días pegandome con paquetes y librerías pero no consigo nada. A ver si alguien ha pasado por esto.
Sistema operativo: debian testing (actualizado)
Escritorio: KDE
Versión de Darktable: 4.0.0
Targeta gráfica: VGA compatible controller: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] (rev a2)
Driver privativo instalado.

Respuesta a: $ darktable -d opencl
[opencl_init] opencl related configuration options:
[opencl_init] opencl: ON
[opencl_init] opencl_scheduling_profile: ‘default’
[opencl_init] opencl_library: ‘default path’
[opencl_init] opencl_device_priority: ‘/!0,///!0,*’
[opencl_init] opencl_mandatory_timeout: 400
[opencl_init] opencl_synch_cache: active module
[opencl_init] opencl library ‘libOpenCL’ found on your system and loaded
[opencl_init] could not get platforms: Unknown OpenCL error
[opencl_init] FINALLY: opencl is NOT AVAILABLE on this system.
[opencl_init] initial status of opencl enabled flag is OFF

Según la página del manual, hay que revisar el archivo de:

En /etc/Opencl/vendors/nvidia.icd solo hay un nombre: libnvidia-opencl.so.1

la librería en cuestión esta en dos sitios en el sistema, pero solo son enlaces simbólicos a otro fichero, que también es un simbólico… y así en bucle. He probado a ponerle la ruta completa en el archivo nvidia.icd pero todo sigue igual.

Creo tener todo instalado. Y creo que no doy para más. Al ser un ordenador viejo me vendría muy bien poner a trabajar la tarjeta gráfica.

Gracias de antemano,
Un saludo,
Iñaki

Hola Iñaki,

Ahora ya no uso Debian :pensive:, cosas de cambiar equipo que ya viene con un sistema preinstalado y con los drivers optimizados para el hardware.

De lo que recuerdo tuve que basarme con los drivers de los repositorios de Debian y me volví loco instalando y desinstalando, hasta que descubri esto: es/NvidiaGraphicsDrivers.

  1. Desinstale los drivers privativos de NVIDIA
  2. Borre todo trazo de nvidia del sistema
  3. Update
  4. Instalar nvidia-detect
  5. Instalar el paquete sugerido.

Nota:
Repositorios non-free activados, cuidado si dispones de cpu AMD, suele dar algún problema.

Con todo esto me funcionaba. Disculpa si te digo cosas que ya conoces.

Saludos y suerte

1 me gusta

Hola Jose,
Lo acabo de intentar pero no me funciona. Sigo igual.
Muchas gracias
Saludos,
iñaki

https://forums.debian.net/viewtopic.php?t=145476

No vamos a bajar los brazos… sigo buscando en mis apuntes…

Saludos.

Me estoy rindiendo.
Muchas gracias por todo.
Creo que me voy a poner a mirar algún equipo con GNU/linux presinstalado y compatibilidad absoluta.
Pero esto se merece otro hilo.
Saludos

Esto de activar Opencl en Linux es una auténtica cruz. Yo tengo un equipo con AMD Ryzen 7 4800 H y no hay forma de activarlo porque necesito los drivers AMD privativos y no hay forma de instalarlos en Mageia. Dice que no es un sistema soportado. Antes tenía un Asus con Intel-Nvidia y me daba de cabezazos igualmente… Lo que no entenderé nunca es si los drivers de AMD están integrados en el kernel linux, porque coño no dan soporte complete a Opencl??? Vaya tela.

1 me gusta

Yo poco puedo ayudar. Siempre he tenido suerte con OpenCL.

Equipo actual:

CPU: 8-Core AMD Ryzen 9 5900HX with Radeon Graphics (-MT MCP-) speed/min/max: 1135/1200/3300 MHz 
Kernel: 5.13.13-051313-generic x86_64 Up: 5m Mem: 3119.9/15400.5 MiB (20.3%) Storage: 1.36 TiB (35.4% used) Procs: 461 
Shell: bash 5.0.17 inxi: 3.0.38 

Sistema Operativo:

ose@titan:~$ neofetch
            .-/+oossssoo+/-.               jose@titan 
        `:+ssssssssssssssssss+:`           ---------- 
      -+ssssssssssssssssssyyssss+-         OS: Ubuntu 20.04.5 LTS x86_64 
    .ossssssssssssssssssdMMMNysssso.       Host: TITAN Standard 
   /ssssssssssshdmmNNmmyNMMMMhssssss/      Kernel: 5.13.13-051313-generic 
  +ssssssssshmydMMMMMMMNddddyssssssss+     Uptime: 6 mins 
 /sssssssshNMMMyhhyyyyhmNMMMNhssssssss/    Packages: 2508 (dpkg), 8 (flatpak), 9 (snap) 
.ssssssssdMMMNhsssssssssshNMMMdssssssss.   Shell: bash 5.0.17 
+sssshhhyNMMNyssssssssssssyNMMMysssssss+   Resolution: 2560x1440, 1680x1050 
ossyNMMMNyMMhsssssssssssssshmmmhssssssso   DE: GNOME 
ossyNMMMNyMMhsssssssssssssshmmmhssssssso   WM: Mutter 
+sssshhhyNMMNyssssssssssssyNMMMysssssss+   WM Theme: Yaru-dark 
.ssssssssdMMMNhsssssssssshNMMMdssssssss.   Theme: Yaru-dark [GTK2/3] 
 /sssssssshNMMMyhhyyyyhdNMMMNhssssssss/    Icons: Yaru [GTK2/3] 
  +sssssssssdmydMMMMMMMMddddyssssssss+     Terminal: gnome-terminal 
   /ssssssssssshdmNNNNmyNMMMMhssssss/      CPU: AMD Ryzen 9 5900HX with Radeon Graphics (16) @ 3.300GHz 
    .ossssssssssssssssssdMMMNysssso.       GPU: NVIDIA 01:00.0 NVIDIA Corporation Device 249d 
      -+sssssssssssssssssyyyssss+-         GPU: AMD ATI 06:00.0 Device 1638 
        `:+ssssssssssssssssss+:`           Memory: 2989MiB / 15400MiB 
            .-/+oossssoo+/-.
                                                                   
                                                                   


jose@titan:~$ 

Tengo dos GPU:

jose@titan:~$ glxheads
glxheads: exercise multiple GLX connections (any key = exit)
Usage:
  glxheads xdisplayname ...
Example:
  glxheads :0 mars:0 venus:1
Name: :1
  Display:     0x55928b451690
  Window:      0x3200002
  Context:     0x55928b5311b8
  GL_VERSION:  4.6.0 NVIDIA 470.141.03
  GL_VENDOR:   NVIDIA Corporation
  GL_RENDERER: NVIDIA GeForce RTX 3070 Laptop GPU/PCIe/SSE2
jose@titan:~$ glxheads
glxheads: exercise multiple GLX connections (any key = exit)
Usage:
  glxheads xdisplayname ...
Example:
  glxheads :0 mars:0 venus:1
Name: :1
  Display:     0x55a20623c190
  Window:      0x3200002
  Context:     0x55a20625d0f0
  GL_VERSION:  4.6 (Compatibility Profile) Mesa 21.2.6
  GL_VENDOR:   AMD
  GL_RENDERER: AMD RENOIR (DRM 3.41.0, 5.13.13-051313-generic, LLVM 12.0.0)

Finalmente a través cde Nvidia settings o de la BIOS, puede acceder a uno u otra gráfica.

Aunque en Gnome es muy facil con darle al botón secundario puedo abrir cualquier programa con la NVIDIA que es algo mas potente que la AMD.

Lo único que hice recien instalado el sistema (Ubuntu LTS) fuen instalar:

# apt install ubuntu-drivers-common

luego

ubuntu-drivers devices

e instalar el paquete que me indique.

En Debian existe dos instrucciones muy relevantes:

Una hace referencia al firmware de nuestros equipos:
instalar este paquete:
# apt install isenkram-cli
# apt isenkram-autoinstall-firmware
Esto instalara el firmware que haga falta.

Lo siguiente es NVIDIA:
# apt install nvidia-detect

Instalar el paquete que os indique el comando.

Aqui teneís las fuentes:
https://packages.debian.org/search?keywords=isenkram
https://wiki.debian.org/es/NvidiaGraphicsDrivers

Finalmente, para saber si teneís instaldo y funcionando OpenCL instalar y ejecutar:
$ clinfo

Saludos y suerte.

Gracias Jose,
Lo he intentado otra vez siguiendo tu consejos, pero solo consigo que no me arranque el sistema gráfico y tener que pelearme en consola para poder restablecer lo básico para poder funcionar.
Por ahora me rindo (estoy empezando a mirar equipos con GNU/linux preinstalado).
Saludos,

Iñaki

Hoy me adelanto a los Reyes Magos y os traigo una buena nueva, para los que utilicéis Mageia 8. De momento un tutorial que próximamente puede que sea un paquete instalable para Mageia 9, de AMD-GPU-PRO para poder activar OpenCl en Mageia. Simplemente, os dejo el enlace con el archivo zip que contiene las instrucciones.

1 me gusta

Muchas gracias. No uso esa distribución soy de .deb de toda la vida, pero nunca se sabe…

Saludos.